rubygem-sanitize20-2.0.6.txz


Advertisement

Description

rubygem-sanitize20 - Whitelist based HTML sanitizer

Property Value
Distribution FreeBSD 12
Repository FreeBSD Ports Quarterly amd64
Package filename rubygem-sanitize20-2.0.6.txz
Package name rubygem-sanitize20
Package version 2.0.6
Package release -
Package architecture amd64
Package type txz
Category rubygems textproc
Homepage https://github.com/rgrove/sanitize
License MIT
Maintainer mfechner@FreeBSD.org
Download size 15.31 KB
Installed size 65.45 KB
Sanitize is a whitelist-based HTML sanitizer.  Given a list of
acceptable elements and attributes, Sanitize will remove all
unacceptable HTML from a string.
Using a simple configuration syntax, you can tell Sanitize to
allow certain elements, certain attributes within those elements,
and even certain URL protocols within attributes that contain URLs.
Any HTML elements or attributes that you don't explicitly allow
will be removed.
WWW: https://github.com/rgrove/sanitize

Alternatives

Package Version Architecture Repository
rubygem-sanitize20-2.0.6.txz 2.0.6 i386 FreeBSD Ports Quarterly
rubygem-sanitize20-2.0.6.txz 2.0.6 amd64 FreeBSD Ports Latest
rubygem-sanitize20-2.0.6.txz 2.0.6 i386 FreeBSD Ports Latest
rubygem-sanitize20 - - -

Requires

Name Value
ruby = 2.4.5_1,1
ruby24-gems = 3.0.3
rubygem-nokogiri = 1.10.1_1

Download

Type URL
Mirror pkg.freebsd.org
Binary Package rubygem-sanitize20-2.0.6.txz
Source Package textproc/rubygem-sanitize20

Install Howto

Install rubygem-sanitize20 txz package:

# pkg install rubygem-sanitize20

See Also

Package Description
rubygem-sass-3.7.4.txz Sass is an extension of CSS3
rubygem-sass-listen-4.0.0.txz Listens to file modifications
rubygem-sass-rails-rails4-6.0.0.txz Sass adapter for the Rails asset pipeline
rubygem-sass-rails-rails5-6.0.0.txz Sass adapter for the Rails asset pipeline
rubygem-sass-rails-rails50-6.0.0.txz Sass adapter for the Rails asset pipeline
rubygem-sass-rails-rails52-6.0.0.txz Sass adapter for the Rails asset pipeline
rubygem-sass32-3.2.19.txz Sass is an extension of CSS3
rubygem-sass34-3.4.25.txz Sass is an extension of CSS3
rubygem-sassc-2.2.1.txz Use libsass with Ruby
rubygem-sassc-rails-rails4-2.1.2_1.txz Integrate SassC-Ruby into Rails
rubygem-sassc-rails-rails5-2.1.2_1.txz Integrate SassC-Ruby into Rails
rubygem-sassc-rails-rails50-2.1.2_1.txz Integrate SassC-Ruby into Rails
rubygem-sassc-rails-rails52-2.1.2_1.txz Integrate SassC-Ruby into Rails
rubygem-savon-2.11.2.txz Library for SOAP communications
rubygem-sawyer-0.8.2.txz Secret User Agent of HTTP
Advertisement
Advertisement