p5-Perl-Critic-Pulp-96.txz


Advertisement

Description

p5-Perl-Critic-Pulp - some add-on perlcritic policies

Property Value
Distribution FreeBSD 12
Repository FreeBSD Ports Quarterly amd64
Package filename p5-Perl-Critic-Pulp-96.txz
Package name p5-Perl-Critic-Pulp
Package version 96
Package release -
Package architecture amd64
Package type txz
Category devel perl5 textproc
Homepage https://metacpan.org/release/Perl-Critic-Pulp
License GPLv1+, ART10
Maintainer perl@FreeBSD.org
Download size 202.45 KB
Installed size 520.28 KB
This is a collection of add-on policies for Perl::Critic. They're under a
"pulp" theme plus other themes according to their purpose (see "POLICY THEMES"
in Perl::Critic).
WWW: https://metacpan.org/release/Perl-Critic-Pulp

Alternatives

Package Version Architecture Repository
p5-Perl-Critic-Pulp-96.txz 96 i386 FreeBSD Ports Quarterly
p5-Perl-Critic-Pulp-96.txz 96 amd64 FreeBSD Ports Latest
p5-Perl-Critic-Pulp-96.txz 96 i386 FreeBSD Ports Latest
p5-Perl-Critic-Pulp - - -

Requires

Name Value
p5-Perl-Critic = 1.132
p5-Perl-MinimumVersion = 1.38_1
p5-Pod-MinimumVersion = 50
perl5 = 5.28.1_1

Download

Type URL
Mirror pkg.freebsd.org
Binary Package p5-Perl-Critic-Pulp-96.txz
Source Package textproc/p5-Perl-Critic-Pulp

Install Howto

Install p5-Perl-Critic-Pulp txz package:

# pkg install p5-Perl-Critic-Pulp

See Also

Package Description
p5-Perl-Critic-Swift-1.0.3.txz A set of additional policies for Perl::Critic
p5-Perl-Critic-Tics-0.009.txz Extra policies for Perl::Critic
p5-Perl-Lint-0.25.txz Yet another Perl source code linter
p5-Perl-Metrics-Lite-0.080_1.txz Perl extension for pluggable Perl Code Metrics System
p5-Perl-Metrics-Simple-0.18.txz Perl extension to count packages, subs, lines, etc. of many files
p5-Perl-MinimumVersion-1.38_1.txz Find a minimum required version of perl for Perl code
p5-Perl-OSType-1.010.txz Map Perl operating system names to generic types
p5-Perl-PrereqScanner-1.023.txz Tool to scan your Perl code for its prerequisites
p5-Perl-PrereqScanner-Lite-0.26.txz Perl extension for lightweight prereqs scanner
p5-Perl-PrereqScanner-NotQuiteLite-0.9908.txz Tool to scan your Perl code for its prerequisites
p5-Perl-Tidy-20190915.txz Indents and reformats Perl scripts to make them easier to read
p5-Perl-Unsafe-Signals-0.03.txz Allow unsafe handling of signals in selected blocks
p5-Perl-Version-1.013_2.txz Parse and manipulate Perl version strings
p5-Perl-osnames-0.11.txz List possible $^O ($OSNAME) values, with description
p5-Perl4-CoreLibs-0.004.txz Libraries historically supplied with Perl 4
Advertisement
Advertisement