liburcu-0.10.1.txz


Advertisement

Description

liburcu - Userspace read-copy-update (RCU) data synchronization library

Property Value
Distribution FreeBSD 12
Repository FreeBSD Ports Quarterly amd64
Package filename liburcu-0.10.1.txz
Package name liburcu
Package version 0.10.1
Package release -
Package architecture amd64
Package type txz
Category sysutils
Homepage http://lttng.org/urcu
License LGPL21
Maintainer mmokhi@FreeBSD.org
Download size 134.98 KB
Installed size 972.84 KB
liburcu is a LGPLv2.1 userspace RCU (read-copy-update)
library. This data synchronization library provides
read-side access which scales linearly with the number
of cores. It does so by allowing multiples copies of a
given data structure to live at the same time, and by
monitoring the data structure accesses to detect grace
periods after which memory reclamation is possible.
WWW: http://lttng.org/urcu
Options:
- DOCS: on

Alternatives

Package Version Architecture Repository
liburcu-0.10.1.txz 0.10.1 i386 FreeBSD Ports Quarterly
liburcu-0.10.1.txz 0.10.1 amd64 FreeBSD Ports Latest
liburcu-0.10.1.txz 0.10.1 i386 FreeBSD Ports Latest
liburcu - - -

Provides

Name Value
liburcu-bp.so.6 -
liburcu-cds.so.6 -
liburcu-common.so.6 -
liburcu-mb.so.6 -
liburcu-qsbr.so.6 -
liburcu-signal.so.6 -
liburcu.so.6 -

Download

Type URL
Mirror pkg.freebsd.org
Binary Package liburcu-0.10.1.txz
Source Package sysutils/liburcu

Install Howto

Install liburcu txz package:

# pkg install liburcu

See Also

Package Description
libusbmuxd-1.0.10.txz Communication interface library for usbmuxd
libusipp-2.24_1.txz Unix socket interface for C++ raw IP/IP6/UDP/TCP, layer 2 framework
libutf-2.10_3.txz UTF-8 character set support library, including regular expressions
libutf-8-1.0,1.txz Unicode conversion routines between UCS-4 and UTF-8
libutf8proc-1.3.1.3.txz UTF8 Processing library
libuutil-1.0.3.txz Illumos userland utilities library
libuv-1.32.0.txz Multi-platform support library with a focus on asynchronous I/O
libuvc-0.0.6.txz Cross-platform library for USB video devices
libv4l-1.6.3_4.txz Video4Linux library
libva-2.5.0.txz VAAPI wrapper and dummy driver
libva-glx-2.5.0.txz VAAPI wrapper for GLX
libva-intel-driver-2.3.0_4.txz VAAPI legacy driver for Intel GMA 4500 (Gen4) or newer
libva-intel-hybrid-driver-1.0.2_2.txz Hybrid VP8 encoder and VP9 decoder for Intel GPUs
libva-intel-media-driver-19.3.p4_1.txz VAAPI driver for Intel HD 5000 (Gen8) or newer
libva-utils-2.5.0_2.txz Collection of tests and utilities for VAAPI
Advertisement
Advertisement