p5-Perl-PrereqScanner-NotQuiteLite-0.9908.txz


Advertisement

Description

p5-Perl-PrereqScanner-NotQuiteLite - Tool to scan your Perl code for its prerequisites

Property Value
Distribution FreeBSD 11
Repository FreeBSD Ports Latest i386
Package filename p5-Perl-PrereqScanner-NotQuiteLite-0.9908.txz
Package name p5-Perl-PrereqScanner-NotQuiteLite
Package version 0.9908
Package release -
Package architecture i386
Package type txz
Category devel perl5
Homepage https://metacpan.org/release/Perl-PrereqScanner-NotQuiteLite
License GPLv1+, ART10
Maintainer sunpoet@FreeBSD.org
Download size 85.14 KB
Installed size 282.78 KB
Perl::PrereqScanner::NotQuiteLite is yet another prerequisites scanner. It
passes almost all the scanning tests for Perl::PrereqScanner and
Module::ExtractUse (ie. except for a few dubious ones), and runs slightly faster
than PPI-based Perl::PrereqScanner. However, it doesn't run as fast as
Perl::PrereqScanner::Lite (which uses an XS lexer).
Perl::PrereqScanner::NotQuiteLite also recognizes eval. Prerequisites in eval
are not considered as requirements, but you can collect them as suggestions.
Conditional requirements or requirements loaded in a block are treated as
recommends. Noed modules are stored separately (since 0.94). You may or may not
need to merge them into requires.
WWW: https://metacpan.org/release/Perl-PrereqScanner-NotQuiteLite

Alternatives

Package Version Architecture Repository
p5-Perl-PrereqScanner-NotQuiteLite-0.9908.txz 0.9908 amd64 FreeBSD Ports Latest
p5-Perl-PrereqScanner-NotQuiteLite-0.9908.txz 0.9908 i386 FreeBSD Ports Quarterly
p5-Perl-PrereqScanner-NotQuiteLite-0.9908.txz 0.9908 amd64 FreeBSD Ports Quarterly
p5-Perl-PrereqScanner-NotQuiteLite - - -

Requires

Name Value
p5-Data-Dump = 1.23_1
p5-Module-CPANfile = 1.1004
p5-Module-Find = 0.13
p5-Regexp-Trie = 0.02
perl5 = 5.30.0

Download

Type URL
Mirror pkg.freebsd.org
Binary Package p5-Perl-PrereqScanner-NotQuiteLite-0.9908.txz
Source Package devel/p5-Perl-PrereqScanner-NotQuiteLite

Install Howto

Install p5-Perl-PrereqScanner-NotQuiteLite txz package:

# pkg install p5-Perl-PrereqScanner-NotQuiteLite

See Also

Package Description
p5-Perl-Tidy-20190915.txz Indents and reformats Perl scripts to make them easier to read
p5-Perl-Unsafe-Signals-0.03.txz Allow unsafe handling of signals in selected blocks
p5-Perl-Version-1.013_2.txz Parse and manipulate Perl version strings
p5-Perl-osnames-0.11.txz List possible $^O ($OSNAME) values, with description
p5-Perl4-CoreLibs-0.004.txz Libraries historically supplied with Perl 4
p5-Perl6-Builtins-0.0.3_2.txz Provide Perl 5 versions of the new Perl 6 builtins
p5-Perl6-Export-0.07_2.txz Implements the Perl 6 'is export(...)' trait
p5-Perl6-Export-Attrs-0.000006.txz Perl 6 'is export(...)' trait as a Perl 5 attribute
p5-Perl6-Form-0.04_2.txz Implements the Perl 6 'form' built-in
p5-Perl6-Junction-1.60000_1.txz Perl6 style Junction operators in Perl5
p5-Perl6-Rules-0.03_1.txz Implements (most of) the Perl 6 regex syntax
p5-Perl6-Say-0.16_1.txz Perl 6 say (print, but no newline needed) function
p5-Perl6-Slurp-0.051005.txz Implements the Perl6 'slurp' built-in
p5-Perl6-Subs-0.05_2.txz Perl6::Subs - Define your subroutines in the Perl 6 style
p5-PerlCryptLib-1.11_1.txz Perl interface to Peter Guttman cryptlib API
Advertisement
Advertisement