rubygem-ruby-openid-2.7.0.txz


Advertisement

Description

rubygem-ruby-openid - OpenID library written in pure Ruby

Property Value
Distribution FreeBSD 11
Repository FreeBSD Ports Latest amd64
Package filename rubygem-ruby-openid-2.7.0.txz
Package name rubygem-ruby-openid
Package version 2.7.0
Package release -
Package architecture amd64
Package type txz
Category net rubygems
Homepage https://github.com/openid/ruby-openid
License APACHE20, RUBY
Maintainer ruby@FreeBSD.org
Download size 271.24 KB
Installed size 1.30 MB
A Ruby library for verifying and serving OpenID identities.
Ruby OpenID makes it easy to add OpenID authentication to your web
applications.
This library is a port of the Python OpenID library, and features:
* API for verifying OpenID identities (OpenID::Consumer)
* API for serving OpenID identities (OpenID::Server)
* Consumer and server support for extensions, including simple registration
* Yadis 1.0 and OpenID 1.0 service discovery, including server fallback
* Does not depend on underlying web framework
* Multiple storage implementations (Filesystem, SQL)
* Comprehensive test suite
* Example code to help you get started, including:
o WEBrick based consumer
o Ruby on rails based server
o OpenIDLoginGenerator for quickly creating a rails app that uses OpenID
for authentication
o ActiveRecord adapter for using an SQL store in rails
WWW: https://github.com/openid/ruby-openid

Alternatives

Package Version Architecture Repository
rubygem-ruby-openid-2.7.0.txz 2.7.0 i386 FreeBSD Ports Quarterly
rubygem-ruby-openid-2.7.0.txz 2.7.0 amd64 FreeBSD Ports Quarterly
rubygem-ruby-openid-2.7.0.txz 2.7.0 i386 FreeBSD Ports Latest
rubygem-ruby-openid - - -

Requires

Name Value
ruby = 2.4.6,1
ruby24-gems = 3.0.3

Download

Type URL
Mirror pkg.freebsd.org
Binary Package rubygem-ruby-openid-2.7.0.txz
Source Package net/rubygem-ruby-openid

Install Howto

Install rubygem-ruby-openid txz package:

# pkg install rubygem-ruby-openid

See Also

Package Description
rubygem-ruby-prof-1.0.0.txz Fast profiler for Ruby
rubygem-ruby-progressbar-1.10.0.txz Progressbar library for Ruby
rubygem-ruby-qmail-0.1.1.txz Ruby qmail library
rubygem-ruby-rc4-0.1.5.txz Pure Ruby implementation of the RC4 algorithm
rubygem-ruby-readability-0.7.0.txz Readability for Ruby
rubygem-ruby-saml-1.9.0.txz SAML toolkit for Ruby on Rails
rubygem-ruby-sdl-ffi-0.4.txz Low-level binding to SDL and related libraries using Ruby-FFI
rubygem-ruby-shout-2.2.2.txz Ruby binding to the libshout library
rubygem-ruby-termios-1.0.2.txz Ruby interface to termios
rubygem-ruby-xslt-0.9.10.txz XSLT processor in pure Ruby
rubygem-ruby-xz-1.0.0.txz Ruby bindings for the liblzma library
rubygem-ruby-yadis-0.3.4.txz Yadis Service discovery library written in pure Ruby
rubygem-ruby2ruby-2.4.1.txz Pure ruby code generator easily from ParseTree's Sexps
rubygem-ruby_dep-1.5.0.txz Creates a version constraint of supported Rubies
rubygem-ruby_expect-1.7.4_1.txz Simple expect implementation
Advertisement
Advertisement