p5-Perl-Critic-More-1.003.txz


Advertisement

Description

p5-Perl-Critic-More - Supplemental policies for Perl::Critic

Property Value
Distribution FreeBSD 11
Repository FreeBSD Ports Latest amd64
Package filename p5-Perl-Critic-More-1.003.txz
Package name p5-Perl-Critic-More
Package version 1.003
Package release -
Package architecture amd64
Package type txz
Category devel perl5 textproc
Homepage https://metacpan.org/release/Perl-Critic-More
License GPLv1+, ART10
Maintainer perl@FreeBSD.org
Download size 31.41 KB
Installed size 58.23 KB
This is a collection of Perl::Critic policies that are not included in the
Perl::Critic core for a variety of reasons:
Experimental
Some policies need some time to work out their kinks, test usability, or
gauge community interest. A subset of these will end up in the core
Perl::Critic someday.
Requires special dependencies
For example, some policies require development versions of PPI (or some
other CPAN module). These will likely end up in the Perl::Critic core when
their dependencies are fulfilled.
Peripheral to Perl
For example, the Editor::RequireEmacsFileVariables policy is metacode.
Also, the Miscellanea::RequireRcsKeywords policy pertains to the
development process, not the code itself. These are not part of
Perl::Critic's mission.
Special purpose
For example, policies like CodeLayout::RequireASCII designed to scratch
itches not felt by most of the community. These will always remain in a
Perl::Critic supplement instead of in the core.
WWW: https://metacpan.org/release/Perl-Critic-More

Alternatives

Package Version Architecture Repository
p5-Perl-Critic-More-1.003.txz 1.003 i386 FreeBSD Ports Quarterly
p5-Perl-Critic-More-1.003.txz 1.003 amd64 FreeBSD Ports Quarterly
p5-Perl-Critic-More-1.003.txz 1.003 i386 FreeBSD Ports Latest
p5-Perl-Critic-More - - -

Requires

Name Value
p5-Perl-Critic = 1.132
perl5 = 5.28.1_1

Download

Type URL
Mirror pkg.freebsd.org
Binary Package p5-Perl-Critic-More-1.003.txz
Source Package textproc/p5-Perl-Critic-More

Install Howto

Install p5-Perl-Critic-More txz package:

# pkg install p5-Perl-Critic-More

See Also

Package Description
p5-Perl-Critic-Pulp-96.txz some add-on perlcritic policies
p5-Perl-Critic-Swift-1.0.3.txz A set of additional policies for Perl::Critic
p5-Perl-Critic-Tics-0.009.txz Extra policies for Perl::Critic
p5-Perl-Lint-0.25.txz Yet another Perl source code linter
p5-Perl-Metrics-Lite-0.080_1.txz Perl extension for pluggable Perl Code Metrics System
p5-Perl-Metrics-Simple-0.18.txz Perl extension to count packages, subs, lines, etc. of many files
p5-Perl-MinimumVersion-1.38_1.txz Find a minimum required version of perl for Perl code
p5-Perl-OSType-1.010.txz Map Perl operating system names to generic types
p5-Perl-PrereqScanner-1.023.txz Tool to scan your Perl code for its prerequisites
p5-Perl-PrereqScanner-Lite-0.26.txz Perl extension for lightweight prereqs scanner
p5-Perl-PrereqScanner-NotQuiteLite-0.9908.txz Tool to scan your Perl code for its prerequisites
p5-Perl-Tidy-20190915.txz Indents and reformats Perl scripts to make them easier to read
p5-Perl-Unsafe-Signals-0.03.txz Allow unsafe handling of signals in selected blocks
p5-Perl-Version-1.013_2.txz Parse and manipulate Perl version strings
p5-Perl-osnames-0.11.txz List possible $^O ($OSNAME) values, with description
Advertisement
Advertisement